Meltdown & Spectre Processor Vulnerabilities

When it comes to the latest security vulnerabilities, these days we hear about things like “Meltdown”, “Spectre” and “Side Chain Vulnerabilities”, all with reference to CVE-2017-5715, CVE-2017-5753, and CVE-2017-5754. Citrix, of course, released several articles on this topic.

What we know is, fixing the operating System is only one side of the medal. You have to update some microcode and BIOS / firmware, too.


Another reminder: if you like to receive E-Mail alerts on Citrix security topics, logon using your Citrix Account ID and browse to https://support.citrix.com/user/alerts. Select the products for which you like to get security alerts. That’s it!

Leave a Reply

Your email address will not be published. Required fields are marked *